Autor Thema: Probleme mit falschen Texten beim E-Mail Versand  (Gelesen 519 mal)

Offline Fasi

  • Jr. Member
  • **
  • Beiträge: 32
Probleme mit falschen Texten beim E-Mail Versand
« am: August 24, 2021, 08:04:32 Vormittag »
Hallo zusammen

Ich habe ein kleines Programm geschrieben mit welchem ich in verschiedenen Zuständen Alarmmeldungen via E-Mail versende, leider taucht plötzlich ein nicht erklärbarer Fehler bei den Meldungen auf.

Kurzer Beschreib:

Bei der Anage handelt es sich um eine Perimeterüberwachung eines Grundstückes. 5 Sensoren belegen I1-5, I7 ist eine manuelle Blockade der Sensoren. I8 ist eine Automatische blockade der Sensoren durch Türen oder Tore. Q1-4 und Q17 sind die Ausgänge der Sensoren welche dann auf eine Videoüberwachung gehen. Q18 ist ein Ausgagng mit welchem ich in diesem Perimeter eine Beleuchtung ansteuere.

Die einzelnen Perimeter werden durch einen Zeitrelais überwacht, ist der Sensor mehr als 2 min belegt wird via E-Mail ein Sabotagealarm ausgesendet.
Ist sind die Sensoren über den I7 manuell blockiert und das länger als 30min kommt ein Erinnerungsmail, wiederholend alle 60min.

E-Mail Meldung Sabotage: Betreff: Sabotagealarm Text: Sabotagealarm, Perimeter xxxxxx
E-Mail Meldung Erinnerung: Betreff: Erinnerung Perimeteruberwachung  Text: Erinnerung! Perimeteruberwachung ist noch manuell ausgeschaltet!


Nun zu meinem Problem...

Es tauchen zwischen durch E-Mail Meldungen auf welche durch einen Sabotagezustand ausgelöst werden, jedoch haben diese Meldungen zwar den Betreff: "Sabotagealarm", aber der Text ist  "Erinnerung! Perimeteruberwachung ist noch manuell ausgeschaltet!".....sprich der Betreff stimmt, jedoch der Text dazu nicht.....

Wie kann das sein? Hat da jemand Rat?

Gruss Chrigu

*** natürlich hier noch die Datei ;-) ***
« Letzte Änderung: August 24, 2021, 09:37:15 Vormittag von Fasi »

Offline w.sprungmann

  • Jr. Member
  • **
  • Beiträge: 78
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #1 am: August 24, 2021, 09:32:02 Vormittag »
Hallo Fasi,
hast du die neuste Firmeware auf der EasyE4 (Version 1.30)?
http://www.moeller.net/update-service/easymfd/OS/easyE4/BaseDevices/easyE4_UPDATE_OS_V130.zip

Es gibt auch eine neue Version von Easysoft 7.31
http://www.moeller.net/update-service/easymfd/731/easySoftV731_setup.exe


« Letzte Änderung: August 24, 2021, 09:35:54 Vormittag von w.sprungmann »

Offline Fasi

  • Jr. Member
  • **
  • Beiträge: 32
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #2 am: August 24, 2021, 09:43:40 Vormittag »
Salüü

Nein die 1.23....war da nicht mal was dass eine Version Probleme mit dem Mail Versand machte?

Ich mach heute Abend mal ein Update....berichte dann wieder...


Gruss Chrigu

Offline Fasi

  • Jr. Member
  • **
  • Beiträge: 32
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #3 am: August 24, 2021, 19:34:54 Nachmittag »
So die Updates sind alle gemacht....

Leider hat es nichts gebracht....habe sogar noch einen weiteren falschen Text....Plötzlich Steht da "Test" im Text und das kommt bei keinem Alarmbausten vor....


Offline Juergen

  • easy god
  • *****
  • Beiträge: 1833
  • Jürgen
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #4 am: August 24, 2021, 19:57:41 Nachmittag »
Hast mal überprüft, ob in der Easy und in der Software am PC der gleiche Stand vom Programm ist?

Zitat
Erinnerung!

Perimeteruberwachung ist noch manuell ausgeschaltet!

Ist bei mir der Text zu Alarmbaustein 1 in deinem Programm
« Letzte Änderung: August 24, 2021, 20:02:32 Nachmittag von Juergen »
Mit freundlichem Gruß Juergen


Alle Programme sind nur Beispiele und Selber zu Testen.
Geprüft wurde nur in der Simulation der Software oder mit Simulator am Schreibtisch. Die Beispiele sind mit Sicherheitsschaltungen zu ergänzen.

Offline Fasi

  • Jr. Member
  • **
  • Beiträge: 32
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #5 am: August 24, 2021, 20:07:56 Nachmittag »
Ja sind gleich....

Das Komische ist ja dass er den Text des ersten Alambaustens mit dem Betreff der folgenden Alarmbausteine vermischt....
Oder neuerdings eben sogar "Test" anstelle des richtigen Texts drinn steht....
« Letzte Änderung: August 24, 2021, 20:11:53 Nachmittag von Fasi »

Offline JansenDa

  • Administrator
  • Newbie
  • *****
  • Beiträge: 4
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #6 am: August 25, 2021, 09:40:27 Vormittag »
Hallo Zusammen,

die Kollegen der Entwicklung werden sich das Thema anschauen und versuchen den Fehler zu reproduzieren.

Gruß
Daniel

Offline Fasi

  • Jr. Member
  • **
  • Beiträge: 32
Antw:Probleme mit falschen Texten beim E-Mail Versand
« Antwort #7 am: September 11, 2021, 11:54:53 Vormittag »
Hallo zusammen

So ich habe nun endlich noch Tests machen können.

Von seiten der Entwickler konnte nichts gefunden werden, sie konnten den Fehler auch nicht reproduzieren.

Mir ist dann aufgefallen dass die gleichen Mails auf dem PC (Outlook) alle stimmen und den Richtigen Text haben.
Jedoch diese auf dem IPhone nicht!

Ich habe nun die Empfänger E-Mal auf eine andere geändert. Bis jetzt scheinen die Mails nun auf dem Iphone auch zu stimmen!
Scheint also ein E-Mail Provider...Handy...irgend was anderes...Fehler gewesen zu sein.

Vielen Dank für die Unterstützng!

Gruss Chrigu