More Information

Autor Thema: Probleme Längenregelung  (Gelesen 655 mal)

Offline manuel88

  • Newbie
  • *
  • Beiträge: 7
Probleme Längenregelung
« am: August 28, 2017, 16:13:41 Nachmittag »
Hallo,
habe große Probleme bei einer Längenregelung. Habe das Programm schon soweit fertig es funktioniert auch auf dem MFD laut Simulation aber wen ich das Programm auf eine easy800 simulieren will funktioniert es nicht, und hier soll das Programm später auch laufen.

Funktionsbeschreibung:
Sollwert: wird im Display eingegeben 0-200mm
Istwert: ist der gezählte Wert der Eingangsimpulse
Regelwert: ist die Differenz aus soll und ist
Zeit: ist die spätere Laufzeit der Schnecke   

Ablaufen soll die Regelung so man gibt die Solllänge vor, die erste Laufzeit wird ohne Regelung berechnet da keine Impulse vorhanden, nächster Durchgang die Istlänge wird mit der Solllänge verglichen und geregelt, die Regellänge wird je nach dem plus oder minus oder gleich der vorherigen Länge gerechnet aus dieser berechneten Länge ergibt sich die Schneckenlaufzeit.
Siehe Programm für die MFD hier funktioniert es.

Bitte um eure Hilfe den Fehler zu finden den ich komme selbst nicht mehr weiter, oder es hat einer einen anderen Lösungsvorschlagt für die Längenregelung.

Gruß
manuel88

Offline AST

  • Jr. Member
  • **
  • Beiträge: 29
Antw:Probleme Längenregelung
« Antwort #1 am: August 29, 2017, 19:37:26 Nachmittag »
Hi Manuel!
Sortiere doch mal die Bausteine im Bausteinplan so wie in dem Programm das läuft.
Ich glaube das sollte dein Problem beheben.

Gruß Andre

Offline manuel88

  • Newbie
  • *
  • Beiträge: 7
Antw:Probleme Längenregelung
« Antwort #2 am: August 30, 2017, 19:24:30 Nachmittag »
Hallo AST,

das ist leider nicht das Problem, da das Programm per Kopie in die Oberfläche der Easy 800 eingefügt wurde.
Sie sind also 100% gleich.

Gruß
manuel88

Offline AST

  • Jr. Member
  • **
  • Beiträge: 29
Antw:Probleme Längenregelung
« Antwort #3 am: September 01, 2017, 15:22:50 Nachmittag »
also bei mir geht das jedenfalls

Offline manuel88

  • Newbie
  • *
  • Beiträge: 7
Antw:Probleme Längenregelung
« Antwort #4 am: September 01, 2017, 16:48:26 Nachmittag »
Hallo AST,

bleibt bei dir im Programm für die easy 800, die berechnete Zeit stehen wenn du den Eingang I3 abschaltest ?
Bei mir funktioniert das nicht beim abschalten von I3 verschwindet der wert.

Gruß
manuel88

Offline AST

  • Jr. Member
  • **
  • Beiträge: 29
Antw:Probleme Längenregelung
« Antwort #5 am: September 01, 2017, 17:03:50 Nachmittag »
Ja, die Zeit bleibt stehen. So wie im Programm mit MFD.
Nochmal, sortiere die Bausteine im Bausteinplan der 800er in die selbe Reihenfolge wie im Bausteinplan beim MFD Programm.
Beim kopieren wird nicht unbedingt der Bausteinplan korrekt übernommen sondern nur der Schaltplan.

Offline manuel88

  • Newbie
  • *
  • Beiträge: 7
Antw:Probleme Längenregelung
« Antwort #6 am: September 04, 2017, 13:35:47 Nachmittag »
Hallo,

also habe meine Bausteinplan von Hand verglichen sie sind Identisch. Kann also der Fehler nicht sein, liegt vielleicht an der Simulation. Kann dies aber momentan nicht auf einer easy 800 testen da ich zurzeit keine mit Display habe. Es wäre super wenn einer von euch das für mich testen würde, da ich unbedingt wissen muss ob es funktioniert.

Gruß
Manuel

Offline manuel88

  • Newbie
  • *
  • Beiträge: 7
Antw:Probleme Längenregelung
« Antwort #7 am: September 04, 2017, 14:48:16 Nachmittag »
Hallo,

Problem gelöst !!!
nach langem testen ist mir eingefallen das ich einen Datenbaustein verwenden kann um das Ergebnis zwischen zu speichern.

Gruß
Manuel