Autor Thema: E4 Modbus poll problem  (Gelesen 1626 mal)

Offline quadro

  • Newbie
  • *
  • Beiträge: 12
E4 Modbus poll problem
« am: Januar 17, 2024, 18:34:36 Nachmittag »
Hi,
Easy E4 is declared to have modbus poll time response of 30ms.
I can't accomplish poll rate near this number and my findings are that Easy E4 can't do this (I have tried ver 6 base module 12TCX1 with firmware 1.42 and now waiting for ver 8 base module to try with firmware 2.02).
I had tried 2 different scada systems and tried with modbus poll and I can not get poll rate bellow 100ms without dropped packages.
Even on 100ms I have some dropped packages as Easy E4 is not able to respond so quickly but 30ms is not possible.
I do not have any load on base module as there are no programm inside but just testing modbus poll rate reading inputs and outputs.
Either it is a problem in firmware or ver 6 HW is too weak for such poll rate but then why Eaton declare 30ms?
I am using E4 connected to Wago 852-1102 switch and SCADA (no load on SCADA except modbus communication to E4) on Ubuntu with low latency kernel so everything is industrial grade but poll is not what is declared.
I can't believe 3 different software packages would have same problem so I can only blame E4.
Anybody tested poll rate and can share findings?
I would like to have response from Eaton guys so we can se can this be improved.
Thank you
« Letzte Änderung: Januar 18, 2024, 17:41:22 Nachmittag von quadro »

Offline Juergen__R

  • Full Member
  • ***
  • Beiträge: 261
  • I love easy-Forum.net
Antw:E4 Modbus poll problem
« Antwort #1 am: Januar 19, 2024, 09:19:19 Vormittag »
Die Beantwortung unangenehmer Feststellungen dauert dann wohl
erfahrungsgemäß länger.
Eine offene Kommunikation wäre für alle - Hersteller und Anwender - hilfreicher!

Schöne Grüße, Jürgen