Autor Thema: Webserver kein Zugang  (Gelesen 1116 mal)

Offline Juergen

  • easy god
  • *****
  • Beiträge: 1672
  • Jürgen
Webserver kein Zugang
« am: Mai 27, 2019, 12:01:35 Nachmittag »
Hallo zusammen :), über Port 80 geht alles normal und habe Zugriff auf den Webserver
Mit Port 443 SSL/TLS geht es nicht.

https://192.xxx.x.xxx geht dann. Natürlich ohne X :)
« Letzte Änderung: Mai 27, 2019, 15:21:13 Nachmittag von Juergen »
Mit freundlichem Gruß Juergen


Alle Programme sind nur Beispiele und Selber zu Testen.
Geprüft wurde nur in der Simulation der Software oder mit Simulator am Schreibtisch. Die Beispiele sind mit Sicherheitsschaltungen zu ergänzen.

Offline Bastler71Bay

  • Jr. Member
  • **
  • Beiträge: 84
    • Meine Homepage
Antw:Webserver kein Zugang
« Antwort #1 am: Juli 18, 2020, 09:27:58 Vormittag »
Hallo und Guten Morgen an Jürgen :) und Alle ,

ich habe mich auch wieder in den letzten Tagen mit der Easy E4 beschäftigt.
Auch habe ich das Node-Red Beispiel durchgemacht.Super Anleitung im .pdf .
Dickes Lob an den Ersteller und Mitwirkenden.
Hat auf Anhieb funktioniert.Leider muß halt immer ein PC,Raspberry Pi oder ähnliches laufen.

Nicht wegen der Stromkosten sondern Versicherungsschutz,Brandgefahr?,Backup uvm.
Sind solche selbst "gebastelten" Geräte in einer (Haus) Versicherung mit abgedeckt?

Zum Webserver:

Ohne SSL/TLS Verschlüsselung geht es anstandlos.
Mit SSL/TLS Verschlüsselung kommen Meldungen im Browser (Firefox 70.0.2 (64-Bit) ) .
Die Webseite hat angeblich kein richtiges Zertifikat usw. .
Mit der Sicherheits- /Ausnahmeregel von Firefox geht dann https://XXX. Easy E4 URL und
im E4 Programm muß bei "Anonymer Lesezugriff erlaubt" ein Haken sein.

Wer hat hier andere Einstellungen und/oder Erfahrungen ?

Firmware Easy E4: FW1.22

CU-Martin

« Letzte Änderung: Juli 18, 2020, 09:35:48 Vormittag von Bastler71Bay »
Es gibt immer Leute die meinen, sie seien schlauer als ich. Das Schlimmste ist, sie sind es auch.

Offline Juergen

  • easy god
  • *****
  • Beiträge: 1672
  • Jürgen
Antw:Webserver kein Zugang
« Antwort #2 am: Juli 18, 2020, 14:25:31 Nachmittag »
Hallo Martin,

habe jetz kein neues Projekt mit dem Webserver versucht.

hatte in der Vergangenheit auch Probleme.
Ohne SSL/TLS Verschlüsselung  ging es auch

Mit SSL/TLS Verschlüsselung musste die Seite auch mit https:// ...  aufgerufen werden.
Nur www. XXX ging nicht
Mit freundlichem Gruß Juergen


Alle Programme sind nur Beispiele und Selber zu Testen.
Geprüft wurde nur in der Simulation der Software oder mit Simulator am Schreibtisch. Die Beispiele sind mit Sicherheitsschaltungen zu ergänzen.